About Me

My Photo
Satya Ghattu's Blog
I work in a financial company where my team provides Architecture, IT, Engineering & Strategic support to Business applications. I worked for BEA Systems (now Oracle) for more than five years as a Senior Software Engineer mainly in the Operations Administration and Management aspects of WebLogic Platform. I possess vast experience in software development excelling in Middleware & Database Components and Core Java/J2EE technologies. I also lead a few open source projects and a contributor on Dev2Dev. Did I mention that I am the original author of WebLogic Scripting Tool (WLST), the official command line tool for WebLogic Platform. I also hold a few software patents, prior to BEA Systems I worked in variety of software industries in various different roles as a Senior Java developer, Software Analyst and as an Oracle DBA. I have a Masters Degree in Engineering from The University Of Akron, Ohio.
View my complete profile

Saturday, July 12, 2008

Java 1.4 and WebLogic 8.1 End Of Life

As you might already know Sun announced End Of Life for JDK 1.4 to be October 2008. Since WebLogic 8.1 runs only on JDK 1.4, BEA announced EOL for WebLogic 8.1.

Continue reading here

2 comments:

ardnetih said...

Weblogic 10.3 is available to download from oracle technology network.

tulasinetu said...

I need a urgent help . We are trying to Migrate our Application from weblogic 8.1 to 10.0 . But i am unable to identify the correct procedure and the major changes that are needed for this migration to become a success . I have been working on this for like 1 month but no success till now .

I fear there might be fingers pointing at me soon from the management as its taking a lot of time . I have had no prior experience with Weblogic sever and its deployment and i am the only one who is working on this project , i tried to follow the BEA Guide for the upgrade but it didnt help much caz its more a generic one and doesnt fir in the way our application is configured.

I am sending a summary of the steps I have taken so far and the issues and concerns I have.

First a Glimpse of our current Environment.

Weblogic server 8.1
JSP’s Front Tier
EJB’s , MDB’s middle Tier
I Planet for authentication purposes
Middlegen-2.0 for Autogenerating CMP’s.
Oakgrovesystems For Workflows within our application
SQL sever 2005
ANT 1.6
Windows XP Professional
Velocity 1.5 Used to generate Template Type Files that are used to generate Stored Procs, Html Files etc

We are planning to migrate to Weblogic 10.0

Here are the steps I have taken so far:

1. Ran the build & deployment procedure in the WLS 8.1 environment.

2. Installed WLS 10.0 in parallel and changed the environment variables pointing to JDK 5.0 and BEA10.

3. Tried to Upgrade the deployed domain using the WebLogic Domain upgrade Wizard. But it says the selected domain directory is already a version 10.0 directory since the config.xml file inside the config folder is version 10.0 xml file, But it does not contain the configurations of the original configuration file that we had for 8.1.

4. When I start the weblogic server using the startweblogic.cmd file that resides in the bin folder of wls 10 , it comes in running mode.

5. After starting the admin console I found datasources, Deployments are all empty. in wls 8.1 we were only concerned with configuring security realm manually but not datasources,Deployments

5. After I try to manually install the ear files and the Datasources [The server starts throwing numerous errors like SQL_SERVER is not a legal value for GeneratorType. The value must be one of the following: Sequence, SequenceTable , I have attached the log file for reference.

6. For the above problem i ran the DDConverter Utility of wls 10.0 which when run across the wrong generators-type tags, creates the correct xml you need to deploy to your app to weblogic.

7. I tried to follow the Bea guide for the upgrade but it’s not helpful enough in our case.

I am unable to find the correct path towards this deployement.

1. Do we need to change our build.xml file and the respective targets inside it?
2. Does the config.xml file needs change and how to do it?

3. During the deployment I found that our build file is pointing to the lib directory of wls 8.1 which has weblogic.jar . That I guess needs a definite change.
4. Do we need middlegen upgrade?
5. Do we need Velocity Upgrade?
5. The startweblogic.cmd now resides in bin directory prior to this it used to reside in the root directory of wls 8.1 and it has numerous references to pointbase server. So in what ways this script must be modified.

Please let me know incase more information is required regarding the current environment or anyother such related things.

Locations of visitors to this page